Asas Tutorial Kemahiran Komputer
[bookmark: window]Windows dan komponennya
Komponen utama yang terdapat pada tetingkap Windows adalah seperti Desktop, My Computer, Recycle Bin, Start Button, Taskbar, dan Shortcuts kepada aplikasi. Anda juga akan menemui tetingkap apabila membuka sesuatu aplikasi. 
[image: Screen shot of Windows and its components]
[bookmark: desktop]Desktop
Skrin pertama yang dilihat apabila membuka komputer. Terdapat folder seperti: My Documents, My Computer, Recycle Bin dan sebarang Shortcuts kepada aplikasi.
[image: Screen shot of Windows Desktop]
[bookmark: taskbar]Taskbar
Taskbar adalah bar pada baris bawah skrin windows yang memaparkan aplikasi-aplikasi yang telah dibuka.
[image: Screen shot of sample Taskbar]
[bookmark: start]Start Menu
Butang Start menyenaraikan submenu bagi aplikasi yang terdapat pada komputer anda.
[image: Screen shot of Start menu]
[bookmark: maximize]Butang Minimize/Maximize/Close 
Pada bahagian atas kiri sudut dokumen, terdapat butang Minimize/Maximize/Close. Minimize membolehkan skrin anda diletakkan pada taskbar. Maximize memaparkan tetingkap dengan saiz besar manakala Close adalah untuk menutup tetingkap anda.
It is best practice to work with your document window maximized. 
[bookmark: mycomputer][image: Screen shot of Minimize/Maximize/Close buttons]





My Computer
When you double-click on the My Computer icon on the desktop, it will open a window similar to the one shown below, where you can navigate between the computer's drives and Control Panel tools.
[image: Screen shot of My Computer window]
[bookmark: click]Right and Left Click
To use the mouse, usually you click the left button. However you can also right-click to display a hidden menu related to the object you are in when clicking. This menu can vary depending on which application you are using.
With right-clicking, you can operate different functions such as:
· Copy/cut or paste a text, file, or folder.
· Rename or delete a file or folder.
[image: Screen shot of example menu on right-click]
[bookmark: multitask]Multitasking
The term multitasking means to be running or working in two or more applications at the same time. You can be more productive by multitasking. For instance, you can download files from the Internet while managing your files or word processing.
In order to switch between the applications you can use the Taskbar, clicking on the icon of the application you want to have in the foreground.
[image: Screen shot of multiple applications open]
[bookmark: highlight]
Highlight
Put your cursor at the beginning of a word or sentence you want to highlight, then click and drag your mouse to the end of the selection.
[image: Example of highlighting, part 1]
[image: Example of highlighting, part 2]
[bookmark: cut]Copy/Cut and Paste Text 
	Copy is used when you want to have an area of text from a document twice at the same document or in another document. You first select the area of the text by highlighting it and then press CTRL+C, or go to Edit menu and select Copy. 
	[image: Screen shot of selecting Copy from the Edit menu]

	Cut is used to delete an area of text from a document. You first select the area of the text by highlighting it and then press CTRL+X, or go to Edit menu and select Cut.
	[image: Screen shot of selecting Cut from the Edit menu]

	Paste is used to insert an area of text or image in a document by hitting CTRL+V or in the Edit menu selecting Paste.
	[image: Screen shot of selecting Paste from the Edit menu]

	Another way of using the copy, cut or paste commands is using the right-click button of your mouse. 
1. After highlighting the text you right-click and a menu will appear where you can select Copy or Cut.
2. To paste you just insert your cursor where you want, right-click and select Paste.
	[image: Selecting Copy by right-clicking]


Copying or cutting and pasting a text in Microsoft Word: 
1. Highlight the text you want to copy or cut, press CTRL+C (for copy) or CTRL+X (for paste).
[image: Highlighting text]
1. Insert your cursor where you want to paste the text.
[image: Inserting your cursor]
1. Paste your text by pressing CTRL+V. The text will appear.
[image: Pasting text]
[bookmark: toolbar]Standard and Formatting Toolbars
Toolbars are rows of buttons and boxes. When you click on a button or box, an application opens or a task is performed. Toolbars normally appear at the top of an application's window. The Standard Toolbar shown in the image below is from Windows Explorer; the standard toolbars in other applications may have buttons that allow youto open a new document, save, print, and spell check.
[image: Screen shot of Standard toolbar in Windows Explorer]

The Formatting Toolbar is used to format a text using alignments, font type, font size, bold, italic, and lists. It is provided in most applications. The image below shows the Formatting Toolbar from Netscape Composer.
[image: Screen shot of Formatting toolbar in Netscape Composer]
[bookmark: save]Save and/or Save As
	[image: Screen shot of selecting Save from the File menu]Save is used when: 
· It is the first time you are saving a file.
· You want to keep saving a existing file in different moments that you are working on it.
· It is the end of a working period.
Note that clicking Save will replace whatever file you were working on.
Go to File menu and select Save or use the combination keys CTRL+S.

	[image: Screen shot of selecting Save As from the File menu]Save As is used when you want to save a file with a different name to create backups of a file in the creation process. In that way, you can have different versions of the same document and can return to a previous stage. 
Go to File menu and select Save As or use the combination keys CTRL+SHIFT+S.


top ↑
[bookmark: print]Print Command
To print a page go to the File menu and select Print. A window will pop up with options for how many copies and which pages you want to print. Other options are also available depending on the printer.
[image: Screen shot of Print window]
[bookmark: newfolder]New Folder
To create a New Folder, which means a new directory (a place where documents from the same subject are stored), go to the File menu, then New and select Folder from the pop-up menu, either in My Computer or in Windows Explorer.
To open Windows Explorer, click the Start button, select Programs/Accessories/Windows Explorer.
[image: Screen shot of creating a new folder in Windows Explorer]
[bookmark: copymove]Copy/Move Files
To copy and move a file or folder, use Windows Explorer.
To open the Explorer application, click the Start button and select Programs and Windows Explorer (some computer have Explorer under Programs/Accessories).
Copy or move a file using Menu command:
1. Select the disk drive that contains the file by clicking twice on it.
2. Click on the folder where the file is located
3. Select the file by clicking on it.
4. Go to Edit menu, select Copy (if you want to retain a copy of the file in the original place) or Cut (if you want to move the file).
5. Navigate to the new location where you want to paste the file.
6. Go to Edit menu, select Paste.
The same procedure can be used if you want to copy or move an entire folder.
[image: Screen shot of selecting Copy from the Edit menu]
[image: Screen shot of selecting Paste from the Edit menu]
[bookmark: drag]Drag and Drop
Drag is when the mouse button is held down while the mouse is moved. It is mostly used to move files around in Windows Explorer or in some other applications. Drop is the release of the button, after finishing dragging the mouse.
Here is an example of dragging and dropping a file from the hard drive to the floppy drive in Windows Explorer:
1. Select the file, hold down the left mouse button and drag it in the direction of the floppy drive on the left side.
[image: Screen shot of Dragging]
1. After the floppy drive highlights you can release the mouse button; the file will be dropped and copied there.
[image: Screen shot of Dropping]
[bookmark: extensions]File Extensions
A file extension is the three letters of a file name after the dot. It is created by the application when you save a file. It is the way operation systems identify which application to use to open a file. Windows often doesn't list them when you are searching for a file, but they are there. Examples are: .txt, .doc, .exe, .html, .jpg, .gif, .wav.
However, sometimes you will want to save a file with different extensions. In order to do that, select Save As in the File menu. The Save As box will open. Choose from the drop-down menu next to Save As Type the type you want to save. The extension of the type will be created for you by the application.
Here is an example from Microsoft Word:
[image: Screen shot of Save As Type box]
Some file extensions:
· Graphic files: .bmp, .gif, .tif, .jpg 
· Word document: .doc
· Program file: .exe 
· Webpages files: .htm, .html
· Unformatted text: .txt
· Excel spreadsheet file: .xls
· Compressed file: .zip
· Rich Formatted Text: .rtf
· Sound file: .wav 
· Acrobat Reader file: .pdf
[bookmark: shortcut]Shortcut
[image: Shortcut icons from the desktop]A shortcut creates a button or icon which typically stays on the desktop and when clicked, quickly allows you to start a program or open a file without having to go to its permanent location on your computer. 
To create a shortcut, open the Windows Explorer or go to the Start menu, select the file or program you want to create a shortcut for, place the cursor on the icon for the file, then right-click and select Create Shortcut from the menu that pops up. The shortcut file will be created. After that, you drag the shortcut file to the desktop and whenever you click on it, it will open the application or document related to the shortcut.
[image: Screen shot of selecting Shortcut from the right-clicked menu of a file in Windows Explorer]
[bookmark: drives]Hard Drive and Floppy Drive
In your computer there are different drives: the hard drive, the floppy drive and the compact disk drive.
The hard drive, also called the C: drive, is used for storing all your applications and files. The floppy drive, or A: drive, is used when you insert a floppy disk to store files that you want to transport or create a back up.
To select the hard drive or floppy drive for file management you can go to either Windows Explorer in programs or to My Computer on the desktop.
In Windows Explorer select the hard or floppy drive.
	Hard Drive C: 
	[image: Selecting hard drive C in Windows Explorer]

	Floppy Drive A:
	[image: Selecting floppy drive A in Windows Explorer]


 
or in My Computer, select the Hard or Floppy Drive.
	Hard Drive C:
	[image: Selecting hard drive C from My Computer]

	Floppy Drive A: 
	[image: Selecting floppy drive A from My Computer]


top ↑
[bookmark: rename]Rename/Delete a Folder or File
Using Windows Explorer you can rename or delete a file or folder.
To Rename a file or folder:
1. Navigate and select the file or folder you want to rename from the proper drive (c:, a:).
2. Go to the File menu and select Rename.
3. The file name will be highlighted and blinking in the right corner waiting for you to type the new file name.
[image: Screen shot of Rename option in File menu]

To Delete a file or folder:
1. Navigate and select the file or folder you want to delete. 
2. Go to the File menu and select Delete. 
[image: Screen shot of Delete option in File menu]
Another way of renaming or deleting a file or folder is using the right-click button of your mouse. After highlighting the file or folder, you right-click and a menu will appear where you can select Rename or Delete.
[bookmark: recycle]Recycle Bin
[image: Recycle Bin Icon]When you delete a file from your computer's hard drive, it is removed to the folder called Recycle Bin. Files deleted from your hard drive are still available for restoring if needed, unless you empty your Recycle Bin.  
· To restore the files, open the Recycle Bin folder by double-clicking the icon on your desktop, select the file and then select Restore.
   
· To clear the Recycle Bin, select Empty Recycle Bin and the files will be permanently removed from your computer. 
[image: Screen shot of Recycle Bin window]
Note that the recycle bin does not apply to the contents of a floppy disk. If you delete a file from a floppy disk, it is permanently deleted, and you cannot restore it.
[bookmark: virus]Virus Checking
A virus is an invasive piece of computer code, usually hidden in executable files posted online, written deliberately to damage computers that run the program. To avoid damage to your own computer system as well as to avoid unwittingly passing viruses on to other users, it is important to regularly use and update virus scanner software.
Purchase
Anti-virus software is available for purchase from many vendors. We recommend that you periodically visit the company's Web site for upgrades and virus news. Popular products for purchase include:
· McAfee VirusScan (http://www.mcafee.com)
· Norton AntiVirus (http://www.symantec.com/nav/nav_9xnt/)
To protect your computer from a virus:
· Run a full system scan each time anti-virus (dat) files are updated.
· Scan everything downloaded from the web with anti-virus software.
· Check every downloaded file before opening it.
1. Save the file to disk. 
2. Run anti-virus software on the selected file. 
3. Open the file. 
When running scan software you will get a window similar to the one below. Browse to select the folder or file you want to scan and click the Scan Now button.
[image: Screen shot of VirusScan window]
Tips: 
· E-mail attachments should never be opened unless one is 100% certain as to the nature of the attachment, who sent it, and why it was sent. Unsolicited e-mail attachments, regardless of who the sender is, should be treated as potential virus hazards. Proceed with caution.
· It is quite difficult for e-mail messages themselves to contain or be a virus, however attachments to messages may indeed contain viruses. Therefore, before opening any file you should first save it to disk and then run the virus detection program.
· Refrain, if possible, from downloading files from questionable Internet sites (for example, sites run by companies or individuals whose true identities are uncertain).
[bookmark: defrag]Defragment Your Hard Drive
Computers store files in pieces of data that can be spread with little space between the data, the fragments. In order to organize the disk space clearing the blank areas, you need to defragment your hard disk using an application.
Go to the Start button, then Programs/Accessories/System Tools, and finally Disk Defragmenter, identify the hard disk you want to defragment and click on the Defragment button, or in the Action menu, select Defragment.
[image: Screen shot of Disk Defragmenter window]
[image: Screen shot of selecting Defragment from the Action menu]
[image: Screen shot of Disk Defragmenter in use]
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